ALSA-2024:4312

See a problem?
Source
https://errata.almalinux.org/9/ALSA-2024-4312.html
Import Source
https://github.com/AlmaLinux/osv-database/blob/master/advisories/almalinux9/ALSA-2024:4312.json
JSON Data
https://api.osv.dev/v1/vulns/ALSA-2024:4312
Related
Published
2024-07-03T00:00:00Z
Modified
2024-07-04T06:32:48Z
Summary
Important: openssh security update
Details

OpenSSH is an SSH protocol implementation supported by a number of Linux, UNIX, and similar operating systems. It includes the core files necessary for both the OpenSSH client and server.

Security Fix(es):

  • openssh: Possible remote code execution due to a race condition in signal handling (CVE-2024-6387)

For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.

References

Affected packages

AlmaLinux:9 / openssh

Package

Name
openssh

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
8.7p1-38.el9_4.1

AlmaLinux:9 / openssh-askpass

Package

Name
openssh-askpass

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
8.7p1-38.el9_4.1

AlmaLinux:9 / openssh-clients

Package

Name
openssh-clients

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
8.7p1-38.el9_4.1

AlmaLinux:9 / openssh-keycat

Package

Name
openssh-keycat

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
8.7p1-38.el9_4.1

AlmaLinux:9 / openssh-server

Package

Name
openssh-server

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
8.7p1-38.el9_4.1

AlmaLinux:9 / pam_ssh_agent_auth

Package

Name
pam_ssh_agent_auth

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.10.4-5.38.el9_4.1