ASB-A-272106880

See a problem?
Import Source
https://storage.googleapis.com/android-osv/ASB-A-272106880.json
JSON Data
https://api.osv.dev/v1/vulns/ASB-A-272106880
Aliases
  • CVE-2023-21114
Published
2024-06-01T00:00:00Z
Modified
2024-07-19T14:41:40Z
Summary
[Mainline Fix] AttributionSource may incorrectly validate the calling uid and pid depending on usage
Details

In multiple locations, there is a possible permission bypass due to a confused deputy. This could lead to local escalation of privilege with no additional execution privileges needed. User interaction is not needed for exploitation.

References

Affected packages

Android / platform/packages/modules/Wifi

Affected ranges

Type
ECOSYSTEM
Events
Introduced
13:0
Fixed
13:2024-06-01

Affected versions

Other

13

Ecosystem specific

{
    "fixes": [
        "https://android.googlesource.com/platform/packages/modules/Wifi/+/0317c109ab6bb2ebcf4a3391279b51a77677bd8e",
        "https://android.googlesource.com/platform/packages/modules/Wifi/+/0751d16cb57e415be037f4f7c962ee55a1f5fe03",
        "https://android.googlesource.com/platform/packages/modules/Wifi/+/e7432d55b04cdb1be06301965757d7f9bd1b4b0d"
    ],
    "spl": "2024-06-01",
    "types": [
        "EoP"
    ],
    "severity": "High"
}