ASB-A-297524203

Import Source
https://storage.googleapis.com/android-osv/ASB-A-297524203.json
Aliases
  • CVE-2024-0031
Published
2024-02-01T00:00:00Z
Modified
2024-03-01T15:40:42Z
Details

In attpbuildreadbytypevaluecmd of att_protocol.cc , there is a possible out of bounds write due to improper input validation. This could lead to remote code execution with no additional execution privileges needed. User interaction is not needed for exploitation.

References

Affected packages

Android / platform/packages/modules/Bluetooth

Affected ranges

Type
ECOSYSTEM
Events
Introduced
11:0
Fixed
11:2024-02-01
Introduced
12:0
Fixed
12:2024-02-01
Introduced
12L:0
Fixed
12L:2024-02-01
Introduced
13:0
Fixed
13:2024-02-01
Introduced
14:0
Fixed
14:2024-02-01

Affected versions

Other

11
12
12L
13
14

Ecosystem specific

{
    "fixes": [
        "https://android.googlesource.com/platform/packages/modules/Bluetooth/+/de53890aaca2ae08b3ee2d6e3fd25f702fdfa661"
    ],
    "spl": "2024-02-01",
    "types": [
        "RCE"
    ],
    "severity": "Critical"
}