BIT-argo-cd-2023-40584

See a problem?
Import Source
https://github.com/bitnami/vulndb/tree/main/data/argo-cd/BIT-argo-cd-2023-40584.json
JSON Data
https://api.osv.dev/v1/vulns/BIT-argo-cd-2023-40584
Aliases
Published
2024-03-06T10:50:42.695Z
Modified
2024-03-06T11:25:28.861Z
Summary
[none]
Details

Argo CD is a declarative continuous deployment for Kubernetes. All versions of ArgoCD starting from v2.4 have a bug where the ArgoCD repo-server component is vulnerable to a Denial-of-Service attack vector. Specifically, the said component extracts a user-controlled tar.gz file without validating the size of its inner files. As a result, a malicious, low-privileged user can send a malicious tar.gz file that exploits this vulnerability to the repo-server, thereby harming the system's functionality and availability. Additionally, the repo-server is susceptible to another vulnerability due to the fact that it does not check the extracted file permissions before attempting to delete them. Consequently, an attacker can craft a malicious tar.gz archive in a way that prevents the deletion of its inner files when the manifest generation process is completed. A patch for this vulnerability has been released in versions 2.6.15, 2.7.14, and 2.8.3. Users are advised to upgrade. The only way to completely resolve the issue is to upgrade, however users unable to upgrade should configure RBAC (Role-Based Access Control) and provide access for configuring applications only to a limited number of administrators. These administrators should utilize trusted and verified Helm charts.

References

Affected packages

Bitnami / argo-cd

Package

Name
argo-cd
Purl
pkg:bitnami/argo-cd

Severity

  • 6.5 (Medium) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H CVSS Calculator

Affected ranges

Type
SEMVER
Events
Introduced
2.4.0
Fixed
2.6.15
Introduced
2.7.0
Fixed
2.7.14
Introduced
2.8.0
Fixed
2.8.3