BIT-argo-cd-2024-32476

See a problem?
Import Source
https://github.com/bitnami/vulndb/tree/main/data/argo-cd/BIT-argo-cd-2024-32476.json
JSON Data
https://api.osv.dev/v1/vulns/BIT-argo-cd-2024-32476
Aliases
Published
2024-05-24T07:16:04.154Z
Modified
2024-06-04T16:56:44.063112Z
Summary
[none]
Details

Argo CD is a declarative, GitOps continuous delivery tool for Kubernetes. There is a Denial of Service (DoS) vulnerability via OOM using jq in ignoreDifferences. This vulnerability has been patched in version(s) 2.10.7, 2.9.12 and 2.8.16.

References

Affected packages

Bitnami / argo-cd

Package

Name
argo-cd
Purl
pkg:bitnami/argo-cd

Severity

  • 6.5 (Medium) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H CVSS Calculator

Affected ranges

Type
SEMVER
Events
Introduced
2.10.0
Fixed
2.10.8
Introduced
2.9.0
Fixed
2.9.13
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.8.17