BIT-cilium-operator-2024-37307

See a problem?
Import Source
https://github.com/bitnami/vulndb/tree/main/data/cilium-operator/BIT-cilium-operator-2024-37307.json
JSON Data
https://api.osv.dev/v1/vulns/BIT-cilium-operator-2024-37307
Aliases
Published
2024-06-17T07:16:41.433Z
Modified
2024-07-15T22:12:02.271702Z
Summary
[none]
Details

Cilium is a networking, observability, and security solution with an eBPF-based dataplane. Starting in version 1.13.0 and prior to versions 1.13.7, 1.14.12, and 1.15.6, the output of cilium-bugtool can contain sensitive data when the tool is run (with the --envoy-dump flag set) against Cilium deployments with the Envoy proxy enabled. Users of the TLS inspection, Ingress with TLS termination, Gateway API with TLS termination, and Kafka network policies with API key filtering features are affected. The sensitive data includes the CA certificate, certificate chain, and private key used by Cilium HTTP Network Policies, and when using Ingress/Gateway API and the API keys used in Kafka-related network policy. cilium-bugtool is a debugging tool that is typically invoked manually and does not run during the normal operation of a Cilium cluster. This issue has been patched in Cilium v1.15.6, v1.14.12, and v1.13.17. There is no workaround to this issue.

References

Affected packages

Bitnami / cilium-operator

Package

Name
cilium-operator
Purl
pkg:bitnami/cilium-operator

Severity

  • 7.9 (High) CVSS_V3 - CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:N CVSS Calculator

Affected ranges

Type
SEMVER
Events
Introduced
1.13.0
Fixed
1.13.17
Introduced
1.14.0
Fixed
1.14.12
Introduced
1.15.0
Fixed
1.15.6