BIT-cilium-proxy-2023-29002

See a problem?
Import Source
https://github.com/bitnami/vulndb/tree/main/data/cilium-proxy/BIT-cilium-proxy-2023-29002.json
JSON Data
https://api.osv.dev/v1/vulns/BIT-cilium-proxy-2023-29002
Aliases
Published
2024-07-01T11:13:02.406Z
Modified
2024-07-01T12:27:07.144974Z
Summary
[none]
Details

Cilium is a networking, observability, and security solution with an eBPF-based dataplane. When run in debug mode, Cilium will log the contents of the cilium-secrets namespace. This could include data such as TLS private keys for Ingress and GatewayAPI resources. An attacker with access to debug output from the Cilium containers could use the resulting output to intercept and modify traffic to and from the affected cluster. Output of the sensitive information would occur at Cilium agent restart, when secrets in the namespace are modified, and on creation of Ingress or GatewayAPI resources. This vulnerability is fixed in Cilium releases 1.11.16, 1.12.9, and 1.13.2. Users unable to upgrade should disable debug mode.

References

Affected packages

Bitnami / cilium-proxy

Package

Name
cilium-proxy
Purl
pkg:bitnami/cilium-proxy

Severity

  • 6.3 (Medium) CVSS_V3 - CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N CVSS Calculator

Affected ranges

Type
SEMVER
Events
Introduced
1.7.0
Fixed
1.11.16
Introduced
1.12.0
Fixed
1.12.9
Introduced
1.13.0
Fixed
1.13.2