BIT-codeigniter-2022-40825

See a problem?
Import Source
https://github.com/bitnami/vulndb/tree/main/data/codeigniter/BIT-codeigniter-2022-40825.json
JSON Data
https://api.osv.dev/v1/vulns/BIT-codeigniter-2022-40825
Aliases
  • CVE-2022-40825
Published
2024-01-31T15:14:08.709Z
Modified
2024-02-19T10:36:29.170Z
Summary
[none]
Details

B.C. Institute of Technology CodeIgniter <=3.1.13 is vulnerable to SQL Injection via system\database\DBquerybuilder.php where_in() function.

References

Affected packages

Bitnami / codeigniter

Package

Name
codeigniter
Purl
pkg:bitnami/codeigniter

Severity

  • 9.8 (Critical) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H CVSS Calculator

Affected ranges

Type
SEMVER
Events
Introduced
3.0.0
Fixed
3.1.13
Type
SEMVER
Events
Introduced
3.0.0
Last affected
3.0.0
Type
SEMVER
Events
Introduced
3.0-rc.0
Last affected
3.0-rc.0
Introduced
3.0-rc2.0
Last affected
3.0-rc2.0
Introduced
3.0-rc3.0
Last affected
3.0-rc3.0