BIT-couchdb-2023-26268

See a problem?
Import Source
https://github.com/bitnami/vulndb/tree/main/data/couchdb/BIT-couchdb-2023-26268.json
JSON Data
https://api.osv.dev/v1/vulns/BIT-couchdb-2023-26268
Aliases
Published
2024-03-06T10:51:14.379Z
Modified
2024-03-06T11:25:28.861Z
Summary
[none]
Details

Design documents with matching document IDs, from databases on the same cluster, may share a mutable Javascript environment when using these design document functions: * validatedocupdate * list * filter * filter views (using view functions as filters) * rewrite * updateThis doesn't affect map/reduce or search (Dreyfus) index functions.Users are recommended to upgrade to a version that is no longer affected by this issue (Apache CouchDB 3.3.2 or 3.2.3).Workaround: Avoid using design documents from untrusted sources which may attempt to cache or store data in the Javascript environment.

References

Affected packages

Bitnami / couchdb

Package

Name
couchdb
Purl
pkg:bitnami/couchdb

Severity

  • 5.3 (Medium) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N CVSS Calculator

Affected ranges

Type
SEMVER
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
3.2.3
Introduced
3.3.0
Fixed
3.3.2