BIT-discourse-2023-25172

See a problem?
Import Source
https://github.com/bitnami/vulndb/tree/main/data/discourse/BIT-discourse-2023-25172.json
JSON Data
https://api.osv.dev/v1/vulns/BIT-discourse-2023-25172
Aliases
Published
2024-03-06T10:59:15.105Z
Modified
2024-03-06T11:25:28.861Z
Summary
[none]
Details

Discourse is an open-source discussion platform. Prior to version 3.0.1 of the stable branch and version 3.1.0.beta2 of the beta and tests-passed branches, a maliciously crafted URL can be included in a user's full name field to to carry out cross-site scripting attacks on sites with a disabled or overly permissive CSP (Content Security Policy). Discourse's default CSP prevents this vulnerability. The vulnerability is patched in version 3.0.1 of the stable branch and version 3.1.0.beta2 of the beta and tests-passed branches. As a workaround, enable and/or restore your site's CSP to the default one provided with Discourse.

References

Affected packages

Bitnami / discourse

Package

Name
discourse
Purl
pkg:bitnami/discourse

Severity

  • 5.4 (Medium) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N CVSS Calculator

Affected ranges

Type
SEMVER
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
3.0.1
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
3.1.0
Type
SEMVER
Events
Introduced
3.1.0-beta1
Last affected
3.1.0-beta1