BIT-discourse-2023-30538

See a problem?
Import Source
https://github.com/bitnami/vulndb/tree/main/data/discourse/BIT-discourse-2023-30538.json
JSON Data
https://api.osv.dev/v1/vulns/BIT-discourse-2023-30538
Aliases
Published
2024-03-06T10:57:47.289Z
Modified
2024-03-06T11:25:28.861Z
Summary
[none]
Details

Discourse is an open source platform for community discussion. Due to the improper sanitization of SVG files, an attacker can execute arbitrary JavaScript on the users’ browsers by uploading a crafted SVG file. This issue is patched in the latest stable and tests-passed versions of Discourse. Users are advised to upgrade. For users unable to upgrade there are two possible workarounds: enable CDN handing of uploads (and ensure the CDN sanitizes SVG files) or disable SVG file uploads by ensuring that the authorized extensions site setting does not include svg (or reset that setting to the default, by default Discourse doesn't enable SVG uploads by users).

References

Affected packages

Bitnami / discourse

Package

Name
discourse
Purl
pkg:bitnami/discourse

Severity

  • 5.4 (Medium) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N CVSS Calculator

Affected ranges

Type
SEMVER
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
3.0.2
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
3.1.0
Type
SEMVER
Events
Introduced
3.1.0-beta1
Last affected
3.1.0-beta1
Introduced
3.1.0-beta2
Last affected
3.1.0-beta2
Introduced
3.1.0-beta3
Last affected
3.1.0-beta3