BIT-discourse-2024-27100

Import Source
https://github.com/bitnami/vulndb/tree/main/data/discourse/BIT-discourse-2024-27100.json
Aliases
Published
2024-04-01T14:04:13.082Z
Modified
2024-04-01T18:50:42.458Z
Details

Discourse is an open source platform for community discussion. In affected versions the endpoints for suspending users, silencing users and exporting CSV files weren't enforcing limits on the sizes of the parameters that they accept. This could lead to excessive resource consumption which could render an instance inoperable. A site could be disrupted by either a malicious moderator on the same site or a malicious staff member on another site in the same multisite cluster. This issue is patched in the latest stable, beta and tests-passed versions of Discourse. Users are advised to upgrade. There are no known workarounds for this vulnerability.

References

Affected packages

Bitnami / discourse

Package

Name
discourse

Affected ranges

Type
SEMVER
Events
Introduced
0The exact introduced commit is unknown
Fixed
3.2.1