BIT-elasticsearch-2023-31419

See a problem?
Import Source
https://github.com/bitnami/vulndb/tree/main/data/elasticsearch/BIT-elasticsearch-2023-31419.json
JSON Data
https://api.osv.dev/v1/vulns/BIT-elasticsearch-2023-31419
Aliases
Published
2024-03-06T10:51:47.965Z
Modified
2024-03-06T11:25:28.861Z
Summary
[none]
Details

A flaw was discovered in Elasticsearch, affecting the _search API that allowed a specially crafted query string to cause a Stack Overflow and ultimately a Denial of Service.

References

Affected packages

Bitnami / elasticsearch

Package

Name
elasticsearch
Purl
pkg:bitnami/elasticsearch

Severity

  • 7.5 (High) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H CVSS Calculator

Affected ranges

Type
SEMVER
Events
Introduced
7.0.0
Fixed
7.17.12
Introduced
8.0.0
Fixed
8.9.0