BIT-envoy-2021-32777

See a problem?
Import Source
https://github.com/bitnami/vulndb/tree/main/data/envoy/BIT-envoy-2021-32777.json
JSON Data
https://api.osv.dev/v1/vulns/BIT-envoy-2021-32777
Aliases
Published
2024-03-06T10:58:27.361Z
Modified
2024-05-19T02:23:55.936450Z
Summary
[none]
Details

Envoy is an open source L7 proxy and communication bus designed for large modern service oriented architectures. In affected versions when ext-authz extension is sending request headers to the external authorization service it must merge multiple value headers according to the HTTP spec. However, only the last header value is sent. This may allow specifically crafted requests to bypass authorization. Attackers may be able to escalate privileges when using ext-authz extension or back end service that uses multiple value headers for authorization. A specifically constructed request may be delivered by an untrusted downstream peer in the presence of ext-authz extension. Envoy versions 1.19.1, 1.18.4, 1.17.4, 1.16.5 contain fixes to the ext-authz extension to correctly merge multiple request header values, when sending request for authorization.

References

Affected packages

Bitnami / envoy

Package

Name
envoy
Purl
pkg:bitnami/envoy

Severity

  • 8.3 (High) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:L CVSS Calculator

Affected ranges

Type
SEMVER
Events
Introduced
1.16.0
Fixed
1.16.5
Introduced
1.17.0
Fixed
1.17.4
Introduced
1.18.0
Fixed
1.18.4
Type
SEMVER
Events
Introduced
1.19.0
Last affected
1.19.0