BIT-git-2024-32004

See a problem?
Import Source
https://github.com/bitnami/vulndb/tree/main/data/git/BIT-git-2024-32004.json
JSON Data
https://api.osv.dev/v1/vulns/BIT-git-2024-32004
Aliases
Published
2024-05-24T07:19:02.349Z
Modified
2024-06-27T07:56:59.386Z
Summary
[none]
Details

Git is a revision control system. Prior to versions 2.45.1, 2.44.1, 2.43.4, 2.42.2, 2.41.1, 2.40.2, and 2.39.4, an attacker can prepare a local repository in such a way that, when cloned, will execute arbitrary code during the operation. The problem has been patched in versions 2.45.1, 2.44.1, 2.43.4, 2.42.2, 2.41.1, 2.40.2, and 2.39.4. As a workaround, avoid cloning repositories from untrusted sources.

References

Affected packages

Bitnami / git

Package

Name
git
Purl
pkg:bitnami/git

Severity

  • 8.1 (High) CVSS_V3 - CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H CVSS Calculator

Affected ranges

Type
SEMVER
Events
Introduced
2.45.0
Fixed
2.45.1
Introduced
2.44.0
Fixed
2.44.1
Introduced
2.43.0
Fixed
2.43.4
Introduced
2.42.0
Fixed
2.42.2
Introduced
2.41.0
Fixed
2.41.1
Introduced
2.40.0
Fixed
2.40.2
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.39.4