BIT-gitlab-2021-39908

See a problem?
Import Source
https://github.com/bitnami/vulndb/tree/main/data/gitlab/BIT-gitlab-2021-39908.json
JSON Data
https://api.osv.dev/v1/vulns/BIT-gitlab-2021-39908
Aliases
Published
2024-03-06T11:17:56.315Z
Modified
2024-03-06T11:25:28.861Z
Summary
[none]
Details

In all versions of GitLab CE/EE starting from 0.8.0 before 14.2.6, all versions starting from 14.3 before 14.3.4, and all versions starting from 14.4 before 14.4.1 certain Unicode characters can be abused to commit malicious code into projects without being noticed in merge request or source code viewer UI.

References

Affected packages

Bitnami / gitlab

Package

Name
gitlab
Purl
pkg:bitnami/gitlab

Severity

  • 7.5 (High) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N CVSS Calculator

Affected ranges

Type
SEMVER
Events
Introduced
0.8.0
Fixed
14.2.6
Introduced
14.3.0
Fixed
14.3.4
Type
SEMVER
Events
Introduced
14.4.0
Last affected
14.4.0