BIT-gitlab-2023-0989

See a problem?
Import Source
https://github.com/bitnami/vulndb/tree/main/data/gitlab/BIT-gitlab-2023-0989.json
JSON Data
https://api.osv.dev/v1/vulns/BIT-gitlab-2023-0989
Aliases
Published
2024-03-06T11:11:45.313Z
Modified
2024-03-06T11:25:28.861Z
Summary
[none]
Details

An information disclosure issue in GitLab CE/EE affecting all versions starting from 13.11 prior to 16.2.8, 16.3 prior to 16.3.5, and 16.4 prior to 16.4.1 allows an attacker to extract non-protected CI/CD variables by tricking a user to visit a fork with a malicious CI/CD configuration.

References

Affected packages

Bitnami / gitlab

Package

Name
gitlab
Purl
pkg:bitnami/gitlab

Severity

  • 5.7 (Medium) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:N/A:N CVSS Calculator

Affected ranges

Type
SEMVER
Events
Introduced
13.11.0
Fixed
16.2.8
Introduced
16.3.0
Fixed
16.3.5
Type
SEMVER
Events
Introduced
16.4.0
Last affected
16.4.0