BIT-gitlab-2023-2620

See a problem?
Import Source
https://github.com/bitnami/vulndb/tree/main/data/gitlab/BIT-gitlab-2023-2620.json
JSON Data
https://api.osv.dev/v1/vulns/BIT-gitlab-2023-2620
Aliases
Published
2024-03-06T11:07:14.968Z
Modified
2024-03-06T11:25:28.861Z
Summary
[none]
Details

An issue has been discovered in GitLab CE/EE affecting all versions starting from 15.1 prior to 15.11.10, all versions from 16.0 prior to 16.0.6, all versions from 16.1 prior to 16.1.1. A maintainer could modify a webhook URL to leak masked webhook secrets by manipulating other masked portions. This addresses an incomplete fix for CVE-2023-0838.

References

Affected packages

Bitnami / gitlab

Package

Name
gitlab
Purl
pkg:bitnami/gitlab

Severity

  • 3.8 (Low) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:N CVSS Calculator

Affected ranges

Type
SEMVER
Events
Introduced
15.1.0
Fixed
15.11.10
Introduced
16.0.0
Fixed
16.0.6
Introduced
16.1.0
Fixed
16.1.1