BIT-gitlab-2023-3994

See a problem?
Import Source
https://github.com/bitnami/vulndb/tree/main/data/gitlab/BIT-gitlab-2023-3994.json
JSON Data
https://api.osv.dev/v1/vulns/BIT-gitlab-2023-3994
Aliases
Published
2024-03-06T11:00:53.875Z
Modified
2024-03-06T11:25:28.861Z
Summary
[none]
Details

An issue has been discovered in GitLab CE/EE affecting all versions starting from 9.3 before 16.0.8, all versions starting from 16.1 before 16.1.3, all versions starting from 16.2 before 16.2.2. A Regular Expression Denial of Service was possible via sending crafted payloads which use ProjectReferenceFilter to the preview_markdown endpoint.

References

Affected packages

Bitnami / gitlab

Package

Name
gitlab
Purl
pkg:bitnami/gitlab

Severity

  • 7.5 (High) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H CVSS Calculator

Affected ranges

Type
SEMVER
Events
Introduced
9.3.0
Fixed
16.0.8
Introduced
16.1.0
Fixed
16.1.3
Introduced
16.2.0
Fixed
16.2.2