BIT-grafana-2024-1313

See a problem?
Import Source
https://github.com/bitnami/vulndb/tree/main/data/grafana/BIT-grafana-2024-1313.json
JSON Data
https://api.osv.dev/v1/vulns/BIT-grafana-2024-1313
Aliases
Published
2024-03-28T07:19:10.064Z
Modified
2024-07-18T07:56:34.499Z
Summary
[none]
Details

It is possible for a user in a different organization from the owner of a snapshot to bypass authorization and delete a snapshot by issuing a DELETE request to /api/snapshots/<key> using its view key. This functionality is intended to only be available to individuals with the permission to write/edit to the snapshot in question, but due to a bug in the authorization logic, deletion requests issued by an unprivileged user in a different organization than the snapshot owner are treated as authorized.Grafana Labs would like to thank Ravid Mazon and Jay Chen of Palo Alto Research for discovering and disclosing this vulnerability.This issue affects Grafana: from 9.5.0 before 9.5.18, from 10.0.0 before 10.0.13, from 10.1.0 before 10.1.9, from 10.2.0 before 10.2.6, from 10.3.0 before 10.3.5.

References

Affected packages

Bitnami / grafana

Package

Name
grafana
Purl
pkg:bitnami/grafana

Severity

  • 6.5 (Medium) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N CVSS Calculator

Affected ranges

Type
SEMVER
Events
Introduced
9.5.0
Fixed
9.5.18
Introduced
10.0.0
Fixed
10.0.13
Introduced
10.1.0
Fixed
10.1.9
Introduced
10.2.0
Fixed
10.2.6
Introduced
10.3.0
Fixed
10.3.5