BIT-jupyter-base-notebook-2024-22421

See a problem?
Import Source
https://github.com/bitnami/vulndb/tree/main/data/jupyter-base-notebook/BIT-jupyter-base-notebook-2024-22421.json
JSON Data
https://api.osv.dev/v1/vulns/BIT-jupyter-base-notebook-2024-22421
Aliases
Published
2024-03-06T10:53:51.269Z
Modified
2024-03-06T11:25:28.861Z
Summary
[none]
Details

JupyterLab is an extensible environment for interactive and reproducible computing, based on the Jupyter Notebook and Architecture. Users of JupyterLab who click on a malicious link may get their Authorization and XSRFToken tokens exposed to a third party when running an older jupyter-server version. JupyterLab versions 4.1.0b2, 4.0.11, and 3.6.7 are patched. No workaround has been identified, however users should ensure to upgrade jupyter-server to version 2.7.2 or newer which includes a redirect vulnerability fix.

References

Affected packages

Bitnami / jupyter-base-notebook

Package

Name
jupyter-base-notebook
Purl
pkg:bitnami/jupyter-base-notebook

Severity

  • 6.5 (Medium) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N CVSS Calculator

Affected ranges

Type
SEMVER
Events
Introduced
7.0.0
Fixed
7.0.7