BIT-liferay-2022-42128

See a problem?
Import Source
https://github.com/bitnami/vulndb/tree/main/data/liferay/BIT-liferay-2022-42128.json
JSON Data
https://api.osv.dev/v1/vulns/BIT-liferay-2022-42128
Aliases
Published
2024-01-31T15:20:01.292Z
Modified
2024-02-19T10:36:29.170Z
Summary
[none]
Details

The Hypermedia REST APIs module in Liferay Portal 7.4.1 through 7.4.3.4, and Liferay DXP 7.4 GA does not properly check permissions, which allows remote attackers to obtain a WikiNode object via the WikiNodeResource.getSiteWikiNodeByExternalReferenceCode API.

References

Affected packages

Bitnami / liferay

Package

Name
liferay
Purl
pkg:bitnami/liferay

Severity

  • 5.3 (Medium) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N CVSS Calculator

Affected ranges

Type
SEMVER
Events
Introduced
7.4.0
Last affected
7.4.0