BIT-mariadb-2020-28912

See a problem?
Import Source
https://github.com/bitnami/vulndb/tree/main/data/mariadb/BIT-mariadb-2020-28912.json
JSON Data
https://api.osv.dev/v1/vulns/BIT-mariadb-2020-28912
Aliases
Published
2024-03-06T11:08:18.607Z
Modified
2024-03-06T11:25:28.861Z
Summary
[none]
Details

With MariaDB running on Windows, when local clients connect to the server over named pipes, it's possible for an unprivileged user with an ability to run code on the server machine to intercept the named pipe connection and act as a man-in-the-middle, gaining access to all the data passed between the client and the server, and getting the ability to run SQL commands on behalf of the connected user. This occurs because of an incorrect security descriptor. This affects MariaDB Server before 10.1.48, 10.2.x before 10.2.35, 10.3.x before 10.3.26, 10.4.x before 10.4.16, and 10.5.x before 10.5.7. NOTE: this issue exists because certain details of the MariaDB CVE-2019-2503 fix did not comprehensively address attack variants against MariaDB. This situation is specific to MariaDB, and thus CVE-2020-28912 does NOT apply to other vendors that were originally affected by CVE-2019-2503.

References

Affected packages

Bitnami / mariadb

Package

Name
mariadb
Purl
pkg:bitnami/mariadb

Severity

  • 7.0 (High) CVSS_V3 - CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H CVSS Calculator

Affected ranges

Type
SEMVER
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
10.1.48
Introduced
10.2.0
Fixed
10.2.35
Introduced
10.3.0
Fixed
10.3.26
Introduced
10.4.0
Fixed
10.4.16
Introduced
10.5.0
Fixed
10.5.7