BIT-mediawiki-2023-22910

See a problem?
Import Source
https://github.com/bitnami/vulndb/tree/main/data/mediawiki/BIT-mediawiki-2023-22910.json
JSON Data
https://api.osv.dev/v1/vulns/BIT-mediawiki-2023-22910
Aliases
Published
2024-03-06T11:03:06.674Z
Modified
2024-03-06T11:25:28.861Z
Summary
[none]
Details

An issue was discovered in MediaWiki before 1.35.9, 1.36.x through 1.38.x before 1.38.5, and 1.39.x before 1.39.1. There is XSS in Wikibase date formatting via wikibase-time-precision-* fields. This allows JavaScript execution by staff/admin users who do not intentionally have the editsitejs capability.

References

Affected packages

Bitnami / mediawiki

Package

Name
mediawiki
Purl
pkg:bitnami/mediawiki

Severity

  • 5.4 (Medium) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N CVSS Calculator

Affected ranges

Type
SEMVER
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.35.9
Introduced
1.36.0
Fixed
1.38.5
Type
SEMVER
Events
Introduced
1.39.0
Last affected
1.39.0
Introduced
1.39.0-rc0
Last affected
1.39.0-rc0
Introduced
1.39.0-rc1
Last affected
1.39.0-rc1