BIT-modsecurity-2024-1019

Import Source
https://github.com/bitnami/vulndb/tree/main/data/modsecurity/BIT-modsecurity-2024-1019.json
Aliases
Published
2024-02-09T07:21:56.096Z
Modified
2024-02-21T07:47:11.466Z
Details

ModSecurity / libModSecurity 3.0.0 to 3.0.11 is affected by a WAF bypass for path-based payloads submitted via specially crafted request URLs. ModSecurity v3 decodes percent-encoded characters present in request URLs before it separates the URL path component from the optional query string component. This results in an impedance mismatch versus RFC compliant back-end applications. The vulnerability hides an attack payload in the path component of the URL from WAF rules inspecting it. A back-end may be vulnerable if it uses the path component of request URLs to construct queries. Integrators and users are advised to upgrade to 3.0.12. The ModSecurity v2 release line is not affected by this vulnerability.

References

Affected packages

Bitnami / modsecurity

Package

Name
modsecurity

Affected ranges

Type
SEMVER
Events
Introduced
3.0.0
Fixed
3.0.12