BIT-moodle-2021-32474

See a problem?
Import Source
https://github.com/bitnami/vulndb/tree/main/data/moodle/BIT-moodle-2021-32474.json
JSON Data
https://api.osv.dev/v1/vulns/BIT-moodle-2021-32474
Aliases
Published
2024-03-06T11:10:14.394Z
Modified
2024-04-23T23:58:33.699049Z
Summary
[none]
Details

An SQL injection risk existed on sites with MNet enabled and configured, via an XML-RPC call from the connected peer host. Note that this required site administrator access or access to the keypair. Moodle 3.10 to 3.10.3, 3.9 to 3.9.6, 3.8 to 3.8.8, 3.5 to 3.5.17 and earlier unsupported versions are affected.

References

Affected packages

Bitnami / moodle

Package

Name
moodle
Purl
pkg:bitnami/moodle

Severity

  • 7.2 (High) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H CVSS Calculator

Affected ranges

Type
SEMVER
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
3.5.18
Introduced
3.8.0
Fixed
3.8.9
Introduced
3.9.0
Fixed
3.9.7
Introduced
3.10.0
Fixed
3.10.4