BIT-moodle-2022-0335

See a problem?
Import Source
https://github.com/bitnami/vulndb/tree/main/data/moodle/BIT-moodle-2022-0335.json
JSON Data
https://api.osv.dev/v1/vulns/BIT-moodle-2022-0335
Aliases
Published
2024-03-06T11:05:44.512Z
Modified
2024-03-06T11:25:28.861Z
Summary
[none]
Details

A flaw was found in Moodle in versions 3.11 to 3.11.4, 3.10 to 3.10.8, 3.9 to 3.9.11 and earlier unsupported versions. The "delete badge alignment" functionality did not include the necessary token check to prevent a CSRF risk.

References

Affected packages

Bitnami / moodle

Package

Name
moodle
Purl
pkg:bitnami/moodle

Severity

  • 8.8 (High) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H CVSS Calculator

Affected ranges

Type
SEMVER
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
3.8.9
Introduced
3.9.0
Fixed
3.9.12
Introduced
3.10.0
Fixed
3.10.9
Introduced
3.11.0
Fixed
3.11.5