BIT-node-2023-30588

Import Source
https://github.com/bitnami/vulndb/tree/main/data/node/BIT-node-2023-30588.json
Aliases
Published
2024-01-31T15:21:05.864Z
Modified
2024-01-31T15:40:39.817Z
Details

When an invalid public key is used to create an x509 certificate using the crypto.X509Certificate() API a non-expect termination occurs making it susceptible to DoS attacks when the attacker could force interruptions of application processing, as the process terminates when accessing public key info of provided certificates from user code. The current context of the users will be gone, and that will cause a DoS scenario. This vulnerability affects all active Node.js versions v16, v18, and, v20.

References

Affected packages

Bitnami / node

Package

Name
node

Affected ranges

Type
SEMVER
Events
Introduced
16.0.0
Fixed
16.20.1
Introduced
18.0.0
Fixed
18.16.1
Introduced
20.0.0
Fixed
20.3.1