BIT-python-2023-36632

See a problem?
Import Source
https://github.com/bitnami/vulndb/tree/main/data/python/BIT-python-2023-36632.json
JSON Data
https://api.osv.dev/v1/vulns/BIT-python-2023-36632
Aliases
Published
2024-03-06T11:03:32.381Z
Modified
2024-03-06T11:25:28.861Z
Summary
[none]
Details

The legacy email.utils.parseaddr function in Python through 3.11.4 allows attackers to trigger "RecursionError: maximum recursion depth exceeded while calling a Python object" via a crafted argument. This argument is plausibly an untrusted value from an application's input data that was supposed to contain a name and an e-mail address. NOTE: email.utils.parseaddr is categorized as a Legacy API in the documentation of the Python email package. Applications should instead use the email.parser.BytesParser or email.parser.Parser class. NOTE: the vendor's perspective is that this is neither a vulnerability nor a bug. The email package is intended to have size limits and to throw an exception when limits are exceeded; they were exceeded by the example demonstration code.

References

Affected packages

Bitnami / python

Package

Name
python
Purl
pkg:bitnami/python

Severity

  • 7.5 (High) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H CVSS Calculator

Affected ranges

Type
SEMVER
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
3.11.4