BIT-python-2024-5642

See a problem?
Import Source
https://github.com/bitnami/vulndb/tree/main/data/python/BIT-python-2024-5642.json
JSON Data
https://api.osv.dev/v1/vulns/BIT-python-2024-5642
Aliases
Published
2024-07-01T10:21:43.501Z
Modified
2024-07-02T07:56:01.842Z
Summary
[none]
Details

CPython 3.9 and earlier doesn't disallow configuring an empty list ("[]") for SSLContext.setnpnprotocols() which is an invalid value for the underlying OpenSSL API. This results in a buffer over-read when NPN is used (see CVE-2024-5535 for OpenSSL). This vulnerability is of low severity due to NPN being not widely used and specifying an empty list likely being uncommon in-practice (typically a protocol name would be configured).

References

Affected packages

Bitnami / python

Package

Name
python
Purl
pkg:bitnami/python

Affected ranges

Type
SEMVER
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
3.10.0