BIT-redis-2023-36824

See a problem?
Import Source
https://github.com/bitnami/vulndb/tree/main/data/redis/BIT-redis-2023-36824.json
JSON Data
https://api.osv.dev/v1/vulns/BIT-redis-2023-36824
Aliases
Published
2024-03-06T11:03:54.180Z
Modified
2024-03-06T11:25:28.861Z
Summary
[none]
Details

Redis is an in-memory database that persists on disk. In Redit 7.0 prior to 7.0.12, extracting key names from a command and a list of arguments may, in some cases, trigger a heap overflow and result in reading random heap memory, heap corruption and potentially remote code execution. Several scenarios that may lead to authenticated users executing a specially crafted COMMAND GETKEYS or COMMAND GETKEYSANDFLAGSand authenticated users who were set with ACL rules that match key names, executing a specially crafted command that refers to a variadic list of key names. The vulnerability is patched in Redis 7.0.12.

References

Affected packages

Bitnami / redis

Package

Name
redis
Purl
pkg:bitnami/redis

Severity

  • 8.8 (High) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H CVSS Calculator

Affected ranges

Type
SEMVER
Events
Introduced
7.0.0
Fixed
7.0.12