BIT-tomcat-2023-46589

Import Source
https://github.com/bitnami/vulndb/tree/main/data/tomcat/BIT-tomcat-2023-46589.json
Aliases
Published
2024-01-31T15:26:36.273Z
Modified
2024-01-31T15:40:39.817Z
Details

Improper Input Validation vulnerability in Apache Tomcat.Tomcat from 11.0.0-M1 through 11.0.0-M10, from 10.1.0-M1 through 10.1.15, from 9.0.0-M1 through 9.0.82 and from 8.5.0 through 8.5.95 did not correctly parse HTTP trailer headers. A trailer header that exceeded the header size limit could cause Tomcat to treat a single request as multiple requests leading to the possibility of request smuggling when behind a reverse proxy.Users are recommended to upgrade to version 11.0.0-M11 onwards, 10.1.16 onwards, 9.0.83 onwards or 8.5.96 onwards, which fix the issue.

References

Affected packages

Bitnami / tomcat

Package

Name
tomcat

Affected ranges

Type
SEMVER
Events
Introduced
8.5.0
Fixed
8.5.96
Introduced
9.0.0
Fixed
9.0.83
Introduced
10.1.0
Fixed
10.1.16
Type
SEMVER
Events
Introduced
11.0.0-milestone1
Last affected
11.0.0-milestone1
Introduced
11.0.0-milestone10
Last affected
11.0.0-milestone10
Introduced
11.0.0-milestone2
Last affected
11.0.0-milestone2
Introduced
11.0.0-milestone3
Last affected
11.0.0-milestone3
Introduced
11.0.0-milestone4
Last affected
11.0.0-milestone4
Introduced
11.0.0-milestone5
Last affected
11.0.0-milestone5
Introduced
11.0.0-milestone6
Last affected
11.0.0-milestone6
Introduced
11.0.0-milestone7
Last affected
11.0.0-milestone7
Introduced
11.0.0-milestone8
Last affected
11.0.0-milestone8
Introduced
11.0.0-milestone9
Last affected
11.0.0-milestone9