BIT-tomcat-2026-101296

See a problem?
Import Source
https://github.com/bitnami/vulndb/tree/main/data/tomcat/BIT-tomcat-2026-101296.json
JSON Data
https://api.osv.dev/v1/vulns/BIT-tomcat-2026-101296
Aliases
  • CVE-2026-101296
Published
2026-10-29T09:01:25Z
Modified
2026-10-29T10:45:13Z
Summary
Apache Tomcat: JNDIRealm bind credential validation fails open for non-GSSAPI SASL mechanisms
Details

A missing critical step in authentication vulnerability in Apache Tomcat when the JNDI realm was configured with with a non GSSAPI SASL authentication mechanism allowed attackers to authenticate without providing the correct password.

This issue affects Apache Tomcat: from 11.0.0 through 11.0.26, from 10.1.0 through 10.1.60, from 9.0.0 through 9.0.122.

The following versions were EOL at the time the CVE was created but are known to be affected: from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Other unsupported versions may also be affected.

Users are recommended to upgrade to version 11.0.27, 10.1.61 or 9.0.123, which fix the issue.

Database specific
{
    "cpes":  [
        "cpe:2.3:a:apache:tomcat:*:*:*:*:*:*:*:*",
        "cpe:2.3:a:apache:tomcat:*:*:*:*:*:maven:*:*"
    ],
    "severity":  "Critical"
}
References

Affected packages

Bitnami / tomcat

Package

Name
tomcat
Purl
pkg:bitnami/tomcat

Severity

  • 9.1 (Critical) CVSS_V4 - CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X CVSS Calculator

Affected ranges

Type
SEMVER
Events
Introduced
7.0.0
Fixed
9.0.123
Introduced
10.1.0
Fixed
10.1.61
Introduced
11.0.0
Fixed
11.0.27

Database specific

source
"https://github.com/bitnami/vulndb/tree/main/data/tomcat/BIT-tomcat-2026-101296.json"