BIT-vault-2023-2121

See a problem?
Import Source
https://github.com/bitnami/vulndb/tree/main/data/vault/BIT-vault-2023-2121.json
JSON Data
https://api.osv.dev/v1/vulns/BIT-vault-2023-2121
Aliases
Published
2024-03-06T11:09:28.191Z
Modified
2024-03-06T11:25:28.861Z
Summary
[none]
Details

Vault and Vault Enterprise's (Vault) key-value v2 (kv-v2) diff viewer allowed HTML injection into the Vault web UI through key values. This vulnerability, CVE-2023-2121, is fixed in Vault 1.14.0, 1.13.3, 1.12.7, and 1.11.11.

References

Affected packages

Bitnami / vault

Package

Name
vault
Purl
pkg:bitnami/vault

Severity

  • 5.4 (Medium) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N CVSS Calculator

Affected ranges

Type
SEMVER
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.11.11
Introduced
1.12.0
Fixed
1.12.7
Introduced
1.13.0
Fixed
1.13.3