BIT-vault-2023-6337

See a problem?
Import Source
https://github.com/bitnami/vulndb/tree/main/data/vault/BIT-vault-2023-6337.json
JSON Data
https://api.osv.dev/v1/vulns/BIT-vault-2023-6337
Aliases
Published
2024-03-06T11:08:02.584Z
Modified
2024-03-06T11:25:28.861Z
Summary
[none]
Details

HashiCorp Vault and Vault Enterprise 1.12.0 and newer are vulnerable to a denial of service through memory exhaustion of the host when handling large unauthenticated and authenticated HTTP requests from a client. Vault will attempt to map the request to memory, resulting in the exhaustion of available memory on the host, which may cause Vault to crash.Fixed in Vault 1.15.4, 1.14.8, 1.13.12.

References

Affected packages

Bitnami / vault

Package

Name
vault
Purl
pkg:bitnami/vault

Severity

  • 7.5 (High) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H CVSS Calculator

Affected ranges

Type
SEMVER
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.12.0
Introduced
1.13.0
Fixed
1.13.12
Introduced
1.14.0
Fixed
1.14.8
Introduced
1.15.0
Fixed
1.15.4