BIT-vault-2024-2877

See a problem?
Import Source
https://github.com/bitnami/vulndb/tree/main/data/vault/BIT-vault-2024-2877.json
JSON Data
https://api.osv.dev/v1/vulns/BIT-vault-2024-2877
Aliases
  • CVE-2024-2877
Published
2024-05-02T07:37:52.117Z
Modified
2024-05-03T06:41:49.986256Z
Summary
[none]
Details

Vault Enterprise, when configured with performance standby nodes and a configured audit device, will inadvertently log request headers on the standby node. These logs may have included sensitive HTTP request information in cleartext.This vulnerability, CVE-2024-2877, was fixed in Vault Enterprise 1.15.8.

References

Affected packages

Bitnami / vault

Package

Name
vault
Purl
pkg:bitnami/vault

Severity

  • 5.5 (Medium) CVSS_V3 - CVSS:3.1/AV:L/AC:L/PR:H/UI:R/S:C/C:H/I:N/A:N CVSS Calculator

Affected ranges

Type
SEMVER
Events
Introduced
1.15.0
Fixed
1.15.8