CVE-2005-1849

See a problem?
Source
https://nvd.nist.gov/vuln/detail/CVE-2005-1849
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2005-1849.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2005-1849
Related
Published
2005-07-26T04:00:00Z
Modified
2024-06-30T12:01:22Z
Summary
[none]
Details

inftrees.h in zlib 1.2.2 allows remote attackers to cause a denial of service (application crash) via an invalid file that causes a large dynamic tree to be produced.

References

Affected packages

Debian:11 / sash

Package

Name
sash
Purl
pkg:deb/debian/sash?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
3.7-5sarge1

Ecosystem specific

{
    "urgency": "low"
}

Debian:12 / sash

Package

Name
sash
Purl
pkg:deb/debian/sash?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
3.7-5sarge1

Ecosystem specific

{
    "urgency": "low"
}

Debian:13 / sash

Package

Name
sash
Purl
pkg:deb/debian/sash?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
3.7-5sarge1

Ecosystem specific

{
    "urgency": "low"
}

Debian:11 / zlib

Package

Name
zlib
Purl
pkg:deb/debian/zlib?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1:1.2.3-1

Ecosystem specific

{
    "urgency": "low"
}

Debian:12 / zlib

Package

Name
zlib
Purl
pkg:deb/debian/zlib?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1:1.2.3-1

Ecosystem specific

{
    "urgency": "low"
}

Debian:13 / zlib

Package

Name
zlib
Purl
pkg:deb/debian/zlib?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1:1.2.3-1

Ecosystem specific

{
    "urgency": "low"
}

Debian:11 / zsync

Package

Name
zsync
Purl
pkg:deb/debian/zsync?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.4.1-1

Ecosystem specific

{
    "urgency": "low"
}

Debian:12 / zsync

Package

Name
zsync
Purl
pkg:deb/debian/zsync?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.4.1-1

Ecosystem specific

{
    "urgency": "low"
}

Debian:13 / zsync

Package

Name
zsync
Purl
pkg:deb/debian/zsync?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.4.1-1

Ecosystem specific

{
    "urgency": "low"
}