CVE-2005-2975

See a problem?
Source
https://nvd.nist.gov/vuln/detail/CVE-2005-2975
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2005-2975.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2005-2975
Related
Published
2005-11-18T06:03:00Z
Modified
2024-06-30T12:01:22Z
Summary
[none]
Details

io-xpm.c in the gdk-pixbuf XPM image rendering library in GTK+ before 2.8.7 allows attackers to cause a denial of service (infinite loop) via a crafted XPM image with a large number of colors.

References

Affected packages

Debian:11 / gdk-pixbuf

Package

Name
gdk-pixbuf
Purl
pkg:deb/debian/gdk-pixbuf?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.22.0-11

Ecosystem specific

{
    "urgency": "low"
}

Debian:12 / gdk-pixbuf

Package

Name
gdk-pixbuf
Purl
pkg:deb/debian/gdk-pixbuf?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.22.0-11

Ecosystem specific

{
    "urgency": "low"
}

Debian:13 / gdk-pixbuf

Package

Name
gdk-pixbuf
Purl
pkg:deb/debian/gdk-pixbuf?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.22.0-11

Ecosystem specific

{
    "urgency": "low"
}

Debian:11 / gtk+2.0

Package

Name
gtk+2.0
Purl
pkg:deb/debian/gtk%2B2.0?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.6.10-2

Ecosystem specific

{
    "urgency": "low"
}

Debian:12 / gtk+2.0

Package

Name
gtk+2.0
Purl
pkg:deb/debian/gtk%2B2.0?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.6.10-2

Ecosystem specific

{
    "urgency": "low"
}

Debian:13 / gtk+2.0

Package

Name
gtk+2.0
Purl
pkg:deb/debian/gtk%2B2.0?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.6.10-2

Ecosystem specific

{
    "urgency": "low"
}