CVE-2006-5298

See a problem?
Source
https://nvd.nist.gov/vuln/detail/CVE-2006-5298
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2006-5298.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2006-5298
Published
2006-10-16T19:07:00Z
Modified
2024-06-30T12:01:22Z
Summary
[none]
Details

The muttadvmktemp function in the Mutt mail client 1.5.12 and earlier does not properly verify that temporary files have been created with restricted permissions, which might allow local users to create files with weak permissions via a race condition between the mktemp and safe_fopen function calls.

References

Affected packages

Debian:11 / mutt

Package

Name
mutt
Purl
pkg:deb/debian/mutt?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.5.13-1.1

Ecosystem specific

{
    "urgency": "low"
}

Debian:12 / mutt

Package

Name
mutt
Purl
pkg:deb/debian/mutt?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.5.13-1.1

Ecosystem specific

{
    "urgency": "low"
}

Debian:13 / mutt

Package

Name
mutt
Purl
pkg:deb/debian/mutt?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.5.13-1.1

Ecosystem specific

{
    "urgency": "low"
}