CVE-2007-1897

See a problem?
Source
https://nvd.nist.gov/vuln/detail/CVE-2007-1897
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2007-1897.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2007-1897
Related
Published
2007-04-09T20:19:00Z
Modified
2024-06-30T12:01:22Z
Summary
[none]
Details

SQL injection vulnerability in xmlrpc (xmlrpc.php) in WordPress 2.1.2, and probably earlier, allows remote authenticated users to execute arbitrary SQL commands via a string parameter value in an XML RPC mt.setPostCategories method call, related to the post_id variable.

References

Affected packages

Debian:11 / wordpress

Package

Name
wordpress
Purl
pkg:deb/debian/wordpress?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.1.3-1

Ecosystem specific

{
    "urgency": "medium"
}

Debian:12 / wordpress

Package

Name
wordpress
Purl
pkg:deb/debian/wordpress?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.1.3-1

Ecosystem specific

{
    "urgency": "medium"
}

Debian:13 / wordpress

Package

Name
wordpress
Purl
pkg:deb/debian/wordpress?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.1.3-1

Ecosystem specific

{
    "urgency": "medium"
}