CVE-2007-4619

See a problem?
Source
https://nvd.nist.gov/vuln/detail/CVE-2007-4619
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2007-4619.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2007-4619
Related
Published
2007-10-12T21:17:00Z
Modified
2024-06-30T12:01:22Z
Summary
[none]
Details

Multiple integer overflows in Free Lossless Audio Codec (FLAC) libFLAC before 1.2.1, as used in Winamp before 5.5 and other products, allow user-assisted remote attackers to execute arbitrary code via a malformed FLAC file that triggers improper memory allocation, resulting in a heap-based buffer overflow.

References

Affected packages

Debian:11 / flac

Package

Name
flac
Purl
pkg:deb/debian/flac?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.2.1-1

Ecosystem specific

{
    "urgency": "medium"
}

Debian:12 / flac

Package

Name
flac
Purl
pkg:deb/debian/flac?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.2.1-1

Ecosystem specific

{
    "urgency": "medium"
}

Debian:13 / flac

Package

Name
flac
Purl
pkg:deb/debian/flac?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.2.1-1

Ecosystem specific

{
    "urgency": "medium"
}