CVE-2007-5585

See a problem?
Source
https://nvd.nist.gov/vuln/detail/CVE-2007-5585
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2007-5585.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2007-5585
Related
Published
2007-10-19T20:17:00Z
Modified
2024-06-30T12:01:22Z
Summary
[none]
Details

xscreensaver 5.03 and earlier, when running without xscreensaver-gl-extras (GL extras) installed, crashes when /usr/bin/xscreensaver-gl-helper does not exist and a user attempts to unlock the screen, which allows attackers with physical access to gain access to the locked session.

References

Affected packages

Debian:11 / xscreensaver

Package

Name
xscreensaver
Purl
pkg:deb/debian/xscreensaver?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.03-3.1

Ecosystem specific

{
    "urgency": "medium"
}

Debian:12 / xscreensaver

Package

Name
xscreensaver
Purl
pkg:deb/debian/xscreensaver?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.03-3.1

Ecosystem specific

{
    "urgency": "medium"
}

Debian:13 / xscreensaver

Package

Name
xscreensaver
Purl
pkg:deb/debian/xscreensaver?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.03-3.1

Ecosystem specific

{
    "urgency": "medium"
}