CVE-2008-0456

See a problem?
Source
https://nvd.nist.gov/vuln/detail/CVE-2008-0456
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2008-0456.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2008-0456
Published
2008-01-25T01:00:00Z
Modified
2024-06-30T12:26:12.817518Z
Summary
[none]
Details

CRLF injection vulnerability in the mod_negotiation module in the Apache HTTP Server 2.2.6 and earlier in the 2.2.x series, 2.0.61 and earlier in the 2.0.x series, and 1.3.39 and earlier in the 1.3.x series allows remote authenticated users to inject arbitrary HTTP headers and conduct HTTP response splitting attacks by uploading a file with a multi-line name containing HTTP header sequences and a file extension, which leads to injection within a (1) "406 Not Acceptable" or (2) "300 Multiple Choices" HTTP response when the extension is omitted in a request for the file.

References

Affected packages

Debian:11 / apache2

Package

Name
apache2
Purl
pkg:deb/debian/apache2?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected

Affected versions

2.*

2.4.48-3.1
2.4.48-3.1+deb11u1
2.4.48-4
2.4.49-1~bpo10+1
2.4.49-1~deb11u1
2.4.49-1~deb11u2
2.4.49-1~deb11u3
2.4.49-1
2.4.49-2
2.4.49-3
2.4.49-4
2.4.50-1~deb11u1
2.4.50-1
2.4.51-1~bpo10+1
2.4.51-1~bpo10+2
2.4.51-1~deb11u1
2.4.51-1
2.4.51-2
2.4.52-1~bpo10+1
2.4.52-1~deb11u1
2.4.52-1~deb11u2
2.4.52-1
2.4.52-2
2.4.52-3
2.4.53-1~deb11u1
2.4.53-1
2.4.53-2~bpo10+1
2.4.53-2
2.4.54-1~deb11u1
2.4.54-1
2.4.54-2
2.4.54-3
2.4.54-4
2.4.54-5
2.4.55-1
2.4.56-1~deb11u1
2.4.56-1~deb11u2
2.4.56-1
2.4.56-2
2.4.57-1
2.4.57-2
2.4.57-3
2.4.58-1
2.4.59-1~deb10u1
2.4.59-1~deb11u1
2.4.59-1~deb12u1
2.4.59-1
2.4.59-2

Ecosystem specific

{
    "urgency": "unimportant"
}

Debian:12 / apache2

Package

Name
apache2
Purl
pkg:deb/debian/apache2?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected

Affected versions

2.*

2.4.57-2
2.4.57-3
2.4.58-1
2.4.59-1~deb10u1
2.4.59-1~deb11u1
2.4.59-1~deb12u1
2.4.59-1
2.4.59-2

Ecosystem specific

{
    "urgency": "unimportant"
}

Debian:13 / apache2

Package

Name
apache2
Purl
pkg:deb/debian/apache2?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected

Affected versions

2.*

2.4.57-2
2.4.57-3
2.4.58-1
2.4.59-1~deb10u1
2.4.59-1~deb11u1
2.4.59-1~deb12u1
2.4.59-1
2.4.59-2

Ecosystem specific

{
    "urgency": "unimportant"
}