CVE-2008-2371

See a problem?
Source
https://nvd.nist.gov/vuln/detail/CVE-2008-2371
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2008-2371.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2008-2371
Related
Published
2008-07-07T23:41:00Z
Modified
2024-06-30T12:01:22Z
Summary
[none]
Details

Heap-based buffer overflow in pcre_compile.c in the Perl-Compatible Regular Expression (PCRE) library 7.7 allows context-dependent attackers to cause a denial of service (crash) or possibly execute arbitrary code via a regular expression that begins with an option and contains multiple branches.

References

Affected packages

Debian:11 / pcre3

Package

Name
pcre3
Purl
pkg:deb/debian/pcre3?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
7.6-2.1

Ecosystem specific

{
    "urgency": "medium"
}

Debian:12 / pcre3

Package

Name
pcre3
Purl
pkg:deb/debian/pcre3?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
7.6-2.1

Ecosystem specific

{
    "urgency": "medium"
}

Debian:13 / pcre3

Package

Name
pcre3
Purl
pkg:deb/debian/pcre3?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
7.6-2.1

Ecosystem specific

{
    "urgency": "medium"
}