CVE-2008-3281

See a problem?
Source
https://nvd.nist.gov/vuln/detail/CVE-2008-3281
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2008-3281.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2008-3281
Related
Published
2008-08-27T20:41:00Z
Modified
2024-06-30T12:01:22Z
Severity
  • 6.5 (Medium) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H CVSS Calculator
Summary
[none]
Details

libxml2 2.6.32 and earlier does not properly detect recursion during entity expansion in an attribute value, which allows context-dependent attackers to cause a denial of service (memory and CPU consumption) via a crafted XML document.

References

Affected packages

Debian:11 / libxml2

Package

Name
libxml2
Purl
pkg:deb/debian/libxml2?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.6.32.dfsg-3

Ecosystem specific

{
    "urgency": "medium"
}

Debian:12 / libxml2

Package

Name
libxml2
Purl
pkg:deb/debian/libxml2?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.6.32.dfsg-3

Ecosystem specific

{
    "urgency": "medium"
}

Debian:13 / libxml2

Package

Name
libxml2
Purl
pkg:deb/debian/libxml2?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.6.32.dfsg-3

Ecosystem specific

{
    "urgency": "medium"
}