CVE-2008-3910

See a problem?
Source
https://nvd.nist.gov/vuln/detail/CVE-2008-3910
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2008-3910.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2008-3910
Published
2008-09-04T17:41:00Z
Modified
2024-06-30T12:01:22Z
Summary
[none]
Details

dns2tcp before 0.4.1 does not properly handle negative values in a certain length field in the input argument to the (1) dnssimpledecode or (2) dns_decode function, which allows remote attackers to overwrite a buffer and have unspecified other impact.

References

Affected packages

Debian:11 / dns2tcp

Package

Name
dns2tcp
Purl
pkg:deb/debian/dns2tcp?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.4.dfsg-2

Ecosystem specific

{
    "urgency": "medium"
}

Debian:12 / dns2tcp

Package

Name
dns2tcp
Purl
pkg:deb/debian/dns2tcp?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.4.dfsg-2

Ecosystem specific

{
    "urgency": "medium"
}

Debian:13 / dns2tcp

Package

Name
dns2tcp
Purl
pkg:deb/debian/dns2tcp?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.4.dfsg-2

Ecosystem specific

{
    "urgency": "medium"
}