CVE-2009-1755

See a problem?
Source
https://nvd.nist.gov/vuln/detail/CVE-2009-1755
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2009-1755.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2009-1755
Related
Published
2009-05-22T11:52:40Z
Modified
2024-06-30T12:01:22Z
Summary
[none]
Details

Off-by-one error in the packetreadquerysection function in packet.c in nsd 3.2.1, and processquery_section in query.c in nsd 2.3.7, allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via unspecified vectors that trigger a buffer overflow.

References

Affected packages

Debian:11 / nsd

Package

Name
nsd
Purl
pkg:deb/debian/nsd?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.3.7-3

Ecosystem specific

{
    "urgency": "medium"
}

Debian:12 / nsd

Package

Name
nsd
Purl
pkg:deb/debian/nsd?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.3.7-3

Ecosystem specific

{
    "urgency": "medium"
}

Debian:13 / nsd

Package

Name
nsd
Purl
pkg:deb/debian/nsd?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.3.7-3

Ecosystem specific

{
    "urgency": "medium"
}