CVE-2010-1634

See a problem?
Source
https://nvd.nist.gov/vuln/detail/CVE-2010-1634
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2010-1634.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2010-1634
Aliases
Published
2010-05-27T19:30:01Z
Modified
2024-06-30T12:01:22Z
Summary
[none]
Details

Multiple integer overflows in audioop.c in the audioop module in Python 2.6, 2.7, 3.1, and 3.2 allow context-dependent attackers to cause a denial of service (application crash) via a large fragment, as demonstrated by a call to audioop.lin2lin with a long string in the first argument, leading to a buffer overflow. NOTE: this vulnerability exists because of an incorrect fix for CVE-2008-3143.5.

References

Affected packages

Debian:11 / python2.7

Package

Name
python2.7
Purl
pkg:deb/debian/python2.7?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.7-1

Ecosystem specific

{
    "urgency": "low"
}