CVE-2010-2480

See a problem?
Source
https://nvd.nist.gov/vuln/detail/CVE-2010-2480
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2010-2480.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2010-2480
Aliases
Published
2010-07-02T19:00:00Z
Modified
2024-06-30T12:01:22Z
Summary
[none]
Details

Mako before 0.3.4 relies on the cgi.escape function in the Python standard library for cross-site scripting (XSS) protection, which makes it easier for remote attackers to conduct XSS attacks via vectors involving single-quote characters and a JavaScript onLoad event handler for a BODY element.

References

Affected packages

Debian:11 / mako

Package

Name
mako
Purl
pkg:deb/debian/mako?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.3.4-1

Ecosystem specific

{
    "urgency": "low"
}

Debian:12 / mako

Package

Name
mako
Purl
pkg:deb/debian/mako?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.3.4-1

Ecosystem specific

{
    "urgency": "low"
}

Debian:13 / mako

Package

Name
mako
Purl
pkg:deb/debian/mako?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.3.4-1

Ecosystem specific

{
    "urgency": "low"
}