CVE-2011-1951

See a problem?
Source
https://nvd.nist.gov/vuln/detail/CVE-2011-1951
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2011-1951.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2011-1951
Published
2011-07-11T20:55:01Z
Modified
2024-06-30T12:01:22Z
Summary
[none]
Details

lib/logmatcher.c in Balabit syslog-ng before 3.2.4, when the global flag is set and when using PCRE 8.12 and possibly other versions, allows remote attackers to cause a denial of service (memory consumption) via a message that does not match a regular expression.

References

Affected packages

Debian:11 / syslog-ng

Package

Name
syslog-ng
Purl
pkg:deb/debian/syslog-ng?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
3.2.4-1

Ecosystem specific

{
    "urgency": "low"
}

Debian:12 / syslog-ng

Package

Name
syslog-ng
Purl
pkg:deb/debian/syslog-ng?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
3.2.4-1

Ecosystem specific

{
    "urgency": "low"
}

Debian:13 / syslog-ng

Package

Name
syslog-ng
Purl
pkg:deb/debian/syslog-ng?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
3.2.4-1

Ecosystem specific

{
    "urgency": "low"
}